Le 10 formule magiche di Excel per diventare un vero professionista

Microsoft Excel ti sembra troppo complicato? Ecco allora 10 formule utili e interessanti, facili da ricordare e applicabili a tutte le tabelle. Il linguaggio “ufficiale” risulta abbastanza ostico, quindi la strategia migliore è quella di seguire ciascun esempio e di applicarlo su Excel mentre leggi l’articolo.

Microsoft Excel è il foglio di calcolo per eccellenza, lodato da molti per la sua innegabile utilità. Eppure continua ad intimorire la maggior parte delle persone che lo utilizzano per la prima volta. Questo programma tentacolare sa fare pressoché tutto e le sue possibilità sono davvero innumerevoli. Con il pacchetto office 2013, questo software è stato ulteriormente migliorato.

La somma semplice (SOMMA)

Questa funzione consente di sommare alcune cifre, come si fa a scuola. Ci sono due modi per farlo.

Il primo permette di sommare il contenuto di celle in sequenza (su una colonna o una riga) scrivendo =SOMMA(prima cella:ultima cella) nella cella in cui vuoi far comparire il risultato.

Variante: Questa formula consente anche di sommare tutte le cifre contenute in un riquadro specifico (su più colonne e più righe), prendendo come prima cella quella più “in alto a sinistra” e come ultima quella più “in basso a destra”.

Negli esempi riportati di seguito “prima cella:ultima cella” comparirà come “intervallo_celle”

Il secondo metodo consente di sommare singole celle (non correlate) scrivendo =SOMMA(cella1;cella2;cella3;cella4) nella cella in cui vuoi far comparire il risultato.

Dimostrazione con esempio:

Somme Excel

Per sommare il contenuto della prima colonna scrivi =SOMMA(A1:A5) nella cella che intendi scegliere per il risultato.
Per sommare tutti i numeri della tabella scrivi nella cella scelta=SOMMA(A1:B5).
Per sommare solo le celle con numero negativo scrivi nella cella scelta=SOMMA(A1:B5).

La somma secondo un criterio specifico (SOMMA.SE)

Attenzione: Questa funzione è disponibile solo per Excel 2007 e le versioni più recenti.

Una tabella può presentarsi come un elenco di dati che non devono obbligatoriamente essere collegati tra loro. Se l’elenco è lungo, potrebbe risultare difficile trovare gli elementi uguali per sommarli uno ad uno. Si può allora chiedere a Excel di trovare determinate celle e di sommarle grazie alla formula =SOMMA.SE(intervallo_celle;”criterio”;somma_intervallo). Con “criterio” si intende la condizione da ricercare nella tabella. L’intervallo_celle corrisponde all’intervallo di celle che contengono il criterio pertinente. La somma_intervallo corrisponde all’intervallo di celle in cui si trovano i numeri da sommare.

Dimostrazione con esempio:

Somme Si Excel

In questo esempio, il criterio da ricercare è “rosso”. Per sommare solo i numeri corrispondenti a “rosso”, scrivi nella cella scelta per il risultato la seguente formula: =SOMMA.SE(B1:B5;”rosso”;A1:A5).

La somma secondo più criteri (SOMMA.PIÙ.SE)

Una tabella può contenere molte informazioni e Excel è in grado di sommare dati codificati secondo criteri diversi grazie alla formula speciale =SOMMA.PIÙ.SE(somma_intervallo;intervallo_criterio1;criterio1;intervallo_criterio2;criterio2;….). Con somma_intervallo si intende l’intervallo di celle in cui si trovano i numeri da sommare. L’intervallo_criterio1 rappresenta l’intervallo di celle che contengono i dati sul primo criterio, l’intervallo_criterio2 si associa chiaramente al secondo criterio e così via. Il criterio1 sarà il primo criterio da ricercare nella tabella e via dicendo.

Dimostrazione con esempio:

Tableau Excel

Per trovare il numero di punti raccolti dagli uomini della squadra gialla scrivi nella cella scelta la seguente formula: SOMMA.PIÙ.SE(D1:D13;C1:C13;C1;B1:B13;B1)

Variante: Non sei obbligato a selezionare esattamente la prima e l’ultima cella della colonna ; puoi anche selezionare un’interna colonna. Al posto di B1:B13 inserisci solo B:B.

La somma di eventi secondo un criterio (CONTA.SE)

Nell’ambito delle statistiche, potrebbe essere interessante sapere quante volte un dato evento si ripete in una colonna. Per questo si può ricorrere alla seguente funzione: =CONTA.SE(intervallo_celle;”criterio”). L’intervallo_celle corrisponde all’intervallo di celle che contengono i dati codificati in cui cercare. Il criterio è il primo criterio da cercare nella tabella.

Dimostrazione con esempio:

Riprendendo la tabella precedente, vuoi sapere quante donne partecipano al gioco. Scrivi nella cella che intendi scegliere per il risultato la seguente formula: =CONTA.SE(B1:B13;”Donne”)

La somma di eventi secondo più criteri (MATR.SOMMA.PRODOTTO)

Questa formula consente di ricavare una statistica per rispondere alla domanda quante volte determinate condizioni sono state soddisfatte nella mia tabella? Risposta: =MATR.SOMMA.PRODOTTO((intervallo_criterio1=”criterio1″)*(intervallo_criterio2=”criterio2″))

L’intervallo_criterio1 rappresenta l’intervallo di celle che contengono i dati sul primo criterio, l’intervallo_criterio2 fa chiaramente riferimento al secondo criterio e così via. Il criterio1 è il primo criterio da ricercare nella tabella e via dicendo.

Dimostrazione con esempio:

Guardando ancora la tabella precedente, questa formula ti permette di sapere per esempio quanti uomini fanno parte della squadra gialla. Scrivi nella cella scelta per il risultato la seguente formula:  =MATR.SOMMA.PRODOTTO((B1:B13=”Uomo”)*(C1:C13=”giallo”))

La somma di eventi compresi tra due valori precisi (MATR.SOMMA.PRODOTTO)

Come avrai capito, MATR.SOMMA.PRODOTTO è uno strumento di statistica che si concentra sul numero di volte in cui determinate condizioni vengono soddisfatte contemporaneamente. È così possibile trovare in una tabella il numero di volte in cui i dati numerici sono compresi tra due valori precisi, grazie alla seguente formula:

=MATR.SOMMA.PRODOTTO(intervallo_celle>=minimo)*(intervallo_celle<=massimo)).

L’intervallo_celle rappresenta l’intervallo di celle che contengono i dati numerici in cui bisogna cercare. Minimo e Massimo sono i due valori all’interno dei quali cercare il risultato.

Dimostrazione con esempio:

Nella stessa tabella, devi trovare il numero di giocatori che hanno ottenuto un punteggio tra 150 e 200. Per questo scrivi nella cella scelta per il risultato la seguente formula:  =MATR.SOMMA.PRODOTTO((D1:D13>=150)*(D1:D13<=200))

La media (MEDIA)

Inutile ricordare cosa sia una media. È anche molto semplice ottenerla con la seguente formula: =MEDIA(intervallo_celle)

L’intervallo_celle rappresenta l’intervallo di celle che contengono i dati codificati in cui cercare.

Dimostrazione con esempio:

Moyenne Excel

Per calcolare la media di tutti questi numeri, scrivi nella cella scelta la seguente formula: =MEDIA(A1:A6)

Il massimo e il minimo (MAX e MIN)

In un insieme di dati troppo ampio, può risultare seccante cercare il risultato numerico più grande e quello più piccolo. Fortunatamente Excel ha una formula per cercarli al tuo posto che è molto semplice da applicare:

=MAX(intervallo_celle)

=MIN(intervallo_celle)

L’intervallo_celle rappresenta l’intervallo di celle che contengono i dati codificati in cui cercare.

Variante: puoi applicare la ricerca a più intervalli di celle. Le formule diventano così:

=MAX(intervallo_celle1; intervallo_celle2)

=MIN(intervallo_celle1; intervallo_celle2)

Dimostrazione con esempio:

Nella tabella precedente, vuoi cercare il valore numerico più alto. Scrivi nella cella scelta la seguente formula: =MAX(A1:A6). Se invece cerchi la cifra più bassa scrivi =MIN(A1:A6). Chiaramente questa formula è utile nelle tabelle molto grandi.

In breve

Anche se all’inizio possono sembrare ostiche, queste formule Excel ti consentono di risparmiare parecchio tempo se utilizzi spesso questo software.

Cerchi un’alternativa a Excel gratuita? Ecco 8 alternative eccellenti alla suite per ufficio Office di Microsoft.

Scarica Microsoft Office 2013

Leggi anche:

Cos’è Office 365 e perché dovresti sceglierlo

Le 5 novità di Microsoft Office 2013 che ti stupiranno

[Articolo originale di Alexander Carlier aggiornato da Baptiste Brassart su Softonic FR]

Visualizzazione commenti in corso...