Pubblicità

Trucchi e Consigli

Come forzare la compatibilità delle estensioni su Firefox

Alessandro Licitra

Pubblicato

Firefox pluginAd ogni update di Firefox l’interrogativo è sempre il medesimo: “funzioneranno le mie estensioni sulla nuova versione“? La risposta è affermativa nella maggior parte dei casi. Ma nella malaugurata circostanza in cui un plugin non superi il controllo di compatibilità, si delineano due possibili scenari: abbandonare l’estensione finché non venga rilasciata una nuova versione (sempre che sia ancora supportata dallo sviluppatore) oppure forzare la compatibilità del plugin modificando manualmente i parametri di configurazione di Firefox.

Ecco i passaggi da eseguire se opti per quest’ultima soluzione, ma fai attenzione, perché  modifiche errate possono compromettere il corretto funzionamento del browser:

  1. Dalla barra degli indirizzi di Firefox digita about:config
  2. Entrato nel menu di configurazione, fai un click tasto destro del mouse e seleziona la voce Nuovo e poi Booleano.about:config
  3. Si aprirà una finestra nella quale inserire la seguente stringa: extensions.checkCompatibility a cui daremo il valore “false”.

    Nuovo booleano Firefox Booleano-False

  4. Ripeti il passaggio precedente (Nuovo –> Booleano) e inserisci la stringa: extensions.checkUpdateSecurity con valore “false”.

In questo modo disabiliteremo i controlli di compatibilità e di sicurezza eseguiti da Firefox sul plugin e potrai provare a reinstallare, stavolta con esito positivo, la tua estensione preferita.

Potrebbe interessarti anche